xTuple.com xTupleU Blog & News Customer Support

xTuple ERP 4.9.0 (final) now available for download

xTuple ERP 4.9.0 is now available from xtuple.org. Note that this release requires plv8.

In support of this final release, we have also published xtDesktop v4.0.1. The new version of xtDesktop shows off a new look for the application and can be toggled on/off if you prefer the old style.

Thank you to everyone who made this release possible.


EDIT: download links updated (2019-06-21 16:45 UTC)
EDIT: github links removed (2019-07-12 14:59 UTC)

Arne,

I've copied the file to the mfg folder as well. You should be able to download it now.

Gil

Hi Gil,

that is great but I do not have access to the enterprise version... I have access to mfg and distribution...

Regards

Arne

Alfredo,

As David pointed out, SourceForge has not been behaving properly for several hours. Therefore I've made the PostBooks reference databases available on the github page for this release.

Gil

The 4.9.0 masterref database for download is really the 4.90 RC masterref database.

Larry,

You're absolutely correct. I've just fixed this problem. Thanks for spotting it so quickly.

Gil

Gil,

 

The databases directory on sourceforge has no 4.9 version, only the installers are present.

 

Regards

 

Alfredo

We have been observing issues with SourceForge today, if you look at the nightlies folder it says April 17th was the last nightly. Not quite sure what is going on there..

Hi--

 

Sourceforge has been losing some of the credibility they use to have.  Also, there's always been a split is repositories regarding where to pick up certain publicly available packages.  Any thought about consolidating packages and such to a single distribution point?  I appreciate that the commercial code has different rules, but this might be an opportunity to streamline this.

Hi Gil,

thank you for the fast help. One step further...: After update starts we get this fault:

Starting Update at Mon Jul 27 18:10:29 2015

Applying database change files...

Import of postbooks_upgrade.sql was successful.

The following error was encountered while trying to import inventory_basic_install.sql into the database:

ERROR:  relation "bomhist" already exists


QPSQL: Unable to create query

 

The upgrade has been aborted due to an error and your database was rolled back to the state it was in when the upgrade was initiated.

Regards

Arne

Arne,

I've posted a temporary solution in the Commercial Downloads section of our website. There is now an Updater package in the ent/4.9.0/Upgrades folder that should allow adding the Manufacturing extension to a Distribution database (there wasn't time to test it thoroughly). The long-term fix will take time and effort that we cannot devote to the task right now.

Gil

Steve,

We've been following the trajectory of SourceForge with great interest and have been discussing in-house how we should respond. Expect some changes in future releases.

Gil

Arne,

There are several paths you can take to install the manufacturing package to your existing distribution database. Here's the simplest:

  • back up your database (again!)
  • connect to the database with psql or pgAdmin or your other query tool of choice
  • reset the "Application" metric to tell the Updater it's talking to a PostBooks database:
    select setMetric('Application', 'PostBooks');
  • use the Updater to process the manufacturing-install-490.gz file
  • verify that the database is OK and that both distribution and manufacturing extensions are working

Gil

trying to update first distribution ends also up in a fault, all green, no error message at start up but once update started (please help!):

Starting Update at Sun Jul 26 13:42:20 2015

Applying database change files...

The following error was encountered while trying to import postbooks_upgrade.sql into the database:

ERROR:  You must supply a valid Sub Account Number.
CONTEXT:  SQL statement "update accnt set accnt_name=''"
PL/pgSQL function inline_code_block line 5 at SQL statement
QPSQL: Unable to create query

 

The upgrade has been aborted due to an error and your database was rolled back to the state it was in when the upgrade was initiated.

 

EDIT:

https://www.xtuple.org/node/4432#comments

 

this one solved at least the update issue to 4.9 on the distribution version (go to Accounting, setup, allow free form sub accounts), still can not change to manufacturing edition...

 

PLEASE HELP, thank you!!!

Hi all,

we are now using the Distribution Version 4.8.1, purchased the Manufacturing edition but there is no update file like e.g. under 4.4 from distribution to manufacturing edition, neither under 4.8.1 nor on 4.9.0. How we shall go ahead?

When using the 4.9.0. Installer it says needs postbooks, when trying the 4.9.0 Updater says needs mfg-edition...

Regards

Arne

Hi Gil,

seems I answered on the old post - see my posting #3.... one step further but not solved....

Looking forward to further thoughts! So far I never had issues I could not solve for myself since 3.X...

Regards

Arne

Arne,

I've created bug 26228 to track this. I'll post a more helpful response as soon as we have a good fix for this problem.

Gil

Arne,

I'm happy to work through this with you further but not in this forum for Announcements. I'll contact you directly.

Gil

Hi Gil,

thank you, the updated worked, see below.... BUT it still says PostBooks on startup...how to make that right?

WORSE! It seems like the functions we paid for are missing now - the module "schedule" is completely gone... GIL, would be more than happy when we could find a fix slowly to make everything working right...

Looking forward to further help...

One more comment - we installed after update also the xtDesktop 4.0.1 and got a first total shock - Chinese translation does not work at all... how to fix this (we had to deactivate it, you can not use Chinese with it)? Any roadmap on that?

Regards

Arne

Starting Update at Thu Jul 30 18:10:20 2015

Applying database change files...

Import of manufacturing_basic_install.sql was successful.

Import of manufacturing_upgrade.sql was successful.

Loading Package Dependencies...

Completed updating dependencies.

The Update is now complete!

Completed Update at Thu Jul 30 18:10:24 2015

Total elapsed time is 0h 0m 4s

 

Hi Gil,

thank you very much, with setting the Application back to "Standard" all fine. We see for actualized translation file of the Chinese xtDesktop version.

Regards

Arne