xTuple.com xTupleU Blog & News Customer Support

Xtuple 4.9.5 missing libraries


I am trying to install xtuple 4.9.5 on fedora 23 (32 bit).  when I ./xtuple from the directory I extracted it into, I get:

Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"
Wed May 4 11:21:18 2016 Warning: Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Wed May 4 11:21:52 2016 Warning: QSqlDatabase: QPSQL7 driver not loaded
Wed May 4 11:21:52 2016 Warning: QSqlDatabase: available drivers: QSQLITE QSQLITE2

I downloaded the missing libraries by "./qt-linux-opensource-5.1.1-x86_64-offline.run" as root.  This resulted in:

/]# find -name libicui*
./usr/lib/libicuio.so.54.1
./usr/lib/libicui18n.so.54.1
./usr/lib/libicui18n.so.54
./usr/lib/libicuio.so.54

However, another attempt to run the xtuple script from the command line yielded the same error message.
I copied all the /lib/libicu* files to the xtuple directory with the same result.

My current guess is that the libraries need to be in some other directory but I do not know which one.

Any help would be appreciated.

I have a very similar case.

I was able to eventually run xtuple (installed on Ubuntu), and I get the following result:

Sun May 8 01:09:51 2016 Warning: QSqlDatabase: QPSQL7 driver not loaded
Sun May 8 01:09:51 2016 Warning: QSqlDatabase: available drivers: QSQLITE
 

What do I need to do to get these drivers?

 

Ideas wil be welcome.

 

Thanks

 

Joseph

I've been using xtuple on Ubuntu 14.04 since last year. This week I upgraded to 4.9.5 and it works OK.

However, the Fedora package has never worked properly. Some missing libraries, and GUI glitches. I'm truly hoping that this is fixed for Fedora 24. There's a bug report for the new packages here: https://bugzilla.redhat.com/show_bug.cgi?id=1307871

@jhogan not sure how to answer a private message on this forum, so I'll do here in case it helps others too

 

xTuple most used software is based on Qt, which consists of several libraries. Your message is just saying that some are missing. I can't replicate your errors though. Where did you get the software and which version?

 

I don't like howtoforge and I'd avoid it as much as I can. My best bet would be to go to the Github releases page  and download the Linux package. It should work well on Ubuntu. You should pay attention and download the right version though. If your computer is relatively new, then it'd be 64-bit. If it's the case download  "xTuple-4.9.5-gc936d99-Linux64.tar.bz2".

Hello,

 

Can you pooint otu where the xtuples files for linux are?

I have never used github.

If the files need to be complied, I know nothing on how to do this.

As for my xTuple version, it is v3.7.2.

If you can point out how to get this, I owudl be grateful.

 

Joseph

That's true for new installations. However, it all depends on what postgresql version you're using. SInce your xtuple version is so old, I would expect postgresql version to be too. It may need updating too.

  Debian and Ubuntu users can install the updater package:

https://packages.qa.debian.org/p/postbooks-updater.html

 

from the official apt repositories and then it will be linked to the correct library versions on their Debian or Ubuntu system.

 

I haven't packaged the updater utility for Fedora yet, as it is a relatively small package to create I left that as an exercise for somebody else in the xTuple community to get started with Fedora packaging, if anybody wants to have a go please feel free to contact me by email to discuss.  I always run the updater on a Debian system myself so I didn't have an urgent need to package it on Fedora either, but if somebody wants to sponsor that work I'm willing to get it done.

 

It may also be better to simply merge the updater into the qt-client repository, that would reduce the number of source packages that need to be supported.  Gil, how would you feel about that?

 

Using the official packages for Debian, Ubuntu or Fedora is definitely better than downloading from Sourceforge or Github, the official packages in each Linux distribution are built and tested for each platform with the corresponding library versions on that platform.  Each time a new Ubuntu version is released, everything is rebuilt with their new libraries.  We are also able to support a range of other architectures such as ARM and POWER and even S390 using the Debian build servers:

 https://buildd.debian.org/status/package.php?p=postbooks&suite=sid

 

What I have concluded is that my life will be easier if I switch to the debian world.  I have about five years of positive experience with centos servers.  They just run, I never even have to look at them.  I have one year of positive experience with fedora 22, it does most of what i need done.  I am starting a new server install with ubuntu 14.  I plan to set up Qt on that server and start hacking.  I design hardware and really love assembly, but I can struggle through c code with help.

Hello,

I like that there seem to be a few solutions to work with the Qt files problems.

I did look at the postbooks updated page, but I do not know what I am looking for.

 

But, For someone who does ot know how to deal with libraries, packages, and compiling, etc....    Is there a program that I can run to install the missing Qt files on my Ubuntu box?

I am slowly converting to Ubuntu, but since xTuple is a program I use on a daily basis, this needs to work too.

Bring that I am slowly converting, this implies that I am still a newbie in the Ubuntu/Linix world when looking at desktop computers.

 

Thanks for letting me know what commands to use, or what programs to install to help solve this Qt files issues.

 

Thanks

 

Joseph

 

 

On Debian and Ubuntu, you can use the "apt-get" command or the Synaptic GUI to install packages

 

e.g.

 

$ sudo apt-get install postbooks postbooks-updater

 

 

On Fedora and RHEL, you can use yum

 

$ sudo yum install postbooks

 

 

The apt-get and yum utilities automatically install the correct dependencies / libraries for you, it should not be necessary to install them manually.

 

Thanks for the quick tip.

 

1 question before I do this.I am using xTuple 3.7.2 GUI.

 

Will this update just want is needed oon the computer, an still be compatible with my v3.7.2?

 

Thanks

 

Joseph

Hi, Joseph:

You are running on a fairly old version. You should consider upgrading. If you look at the supported versions document on our website, you can see that the version you are on is no longer supported.

xTuple does provide upgrading services if you are interested.

Best regards,

Pierce

Qt is client GUI technology, how are you going to use it on the server? I'm a CentOS/Fedora guy, so I'd be interested to know what your next setup is going to be. Is it remote desktop?

xTuple is written in the Qt environment.  I plan to use it to run my business.  I am not comfortable managing something I do not fully understand.  Being able to edit and compile the source appeals to me.  Learning one more environment is a small price to pay.

Well, I am far enough along in my switch to ubuntu to hit a very puzzling warning message.  This took a little while since I needed to try out several different ubuntu spins for both the server and client.  I can report that the prebuilt binaries do install painlessly on both boxes.  When logging into the postgres server with the xtuple gui, I get a warning message that postgres 9.5.3 is compatible with xtuple 4.9.1 up to but not including 4.9.5.  The compatibility matrix lists xtuple 4.9.2 to 4.9.5 with postgres 9.1 to 9.4 for linux.  Since postgres 9.5.x is not in the matrix I assumed that the matrix is a little behind.  When I ignore the warning and run the gui client with the server, everything I have tried so far seems to be working.  I started the whole upgrade project because my previous version pair (postgres 9.4.1 and xtuple 4.8.0) could do everything but print.  That problem is fixed in the new pair.  This is encouraging progress and I will continue to ignore the warning.  If anybody knows why I should take it seriously, please tell me.

Hi,

The compatibility matrix is up-to-date, so I wouldn't rule out possible conflicts with your Postgres 9.5.

Best regards,

Pierce

Looks like I'm the test pilot.

Hello again,

 

Thanks for the ideas.

 

When I update these, will this still be compatible with v3.7.2 xTuple?  ONce i update, I probably can not go backwards.

 

Thanks for your reply.

 

Joseph

xTuple doesn't work on Fedora since release 23. I reported this bug and it's still unresolved https://www.xtuple.org/xtincident/view/bugs/27099

Postgresql 9.5 works fine with xTuple 4.9.5 and Ubuntu as that's what I am currently using

Just backup your database https://www.postgresql.org/docs/current/static/backup.html

With a good backup there's no risk you'll lose any data