xTuple.com xTupleU Blog & News Customer Support

Wecome Screen Editing

Hi, forgive me for such a dump question but as the saying goes, “anything you don’t know is older than you”.

I have made lot of changes to the xTuple application per requested by my boss except that I need to disable or hide the Welcome to xTuple screen that display when you log in. I believe that it gets pull from the internet because when I disconnect my computer from the internet, I don’t get the graphics and other text but rather this message “You are not connected to the internet at this time”

I would like to make that page blank and later write some graphically reports that will be display but for now if I can just disable or hide that page- it will save me.


Sorry, turning off the welcome page is a feature we only make available to our commercial customers.

Thanks ned - how do we become commercial customers? We are not only using the product but we intend customizing it for different clients.

If you haven’t already, please have a look at www.xtuple.com/partnerprograms. I’ll also ask Danielle Kerner, who heads up our partner programs, to drop you a line.


As stated above, turning off the welcome page is a feature we only make available to our commercial customers.

The simple solution to getting rid of the “welcome” screen in xTuple, you can either disable the xtdesktop extension (System>Design>Packages) or change your user preferences (System>User Preferences> Application tab>Show Windows as Free Floating) as desktop only runs while Windows are limited to the workspace. In User Preferences you can set your desktop workspace to display any photo or background you wish.

i am a commercial customer. How do I turn off the welcome page? I like the rest of the desktop, but not the welcome page.
Can it be altered to be my companies logo? Maybe with a message of my choosing?


Good day,

How to load a screen upon logging in xtuple postbook instead of the welcome screen. 

Please help.


Not using a VPN.

The welcome screen says "

Welcome to xTuple


You are not connected to the internet at this time"


But I am since I am posting this.



Sometimes we see that message when there is a problem with the welcome webpage (which is hosted in a Rackspace datacenter).  But that doesn't appear to be the case currently.  Maybe a hiccup in your internal network?

If you can access your local PostBooks database in the other screens, you can safely ignore the message regardless... although we're sad you're missing the community messaging we put there!

This means that the computer with PostgreSQL on it or the computer using the front end GUI can not access the interent. I would check all your IP address settings. 

I am working remotely from a client over the Internet to the server with PostgreSQL. All of the functionality of Postbooks is working. The issue is that the content of the Welcome screen is not being retrieved.

Do you know the IP or name of the server that serves that content. I will check our firewall rules to see if it is being blocked.


Are you connecting via VPN, then running locally? when you connect can you still browse the internet. A lot of times when you create a VPN connection you need to change your settings to be able to connect and still browse the internet, that may be your problem with the welcome screen.

How are you connecting remotely? do you have the port forwarded? and what about browsing the internet while connected?

I am posting from the same computer that I use for the Postbooks client.


The client connects over the Internet to another router which does port forwarding to the PostgreSQL database.


It has been noted that if you are using Ubuntu 12.10 then the Welcome screen can display that message.


(not sure if the link will be visible to you)



An incident is being created to track this.

this is the welcome link:



if you can open the link then the welcome screen should show when you login.

elevow - On Fedora 17


tomdatkins - I can open that link in Firefox