xTuple.com xTupleU Blog & News Customer Support

Upgrading 3.2.2 xtpos to 3.3.0 xtpos Beta

Greetings Folks!

I have 3.2.2 with xtpos installed. I am upgrading PostBooks to 3.3.0.

I have a database update error that occurred during the 3.2.2->3.3.0 update which says:

The following error was encountered while trying to import 322to330alpha/deleteOldTaxCodes.sql into the database: ERROR: update or delete on table “tax” violates foreign key constraint “saleitem_saleitem_tax_id_fkey” on table “saleitem” DETAIL: Key(tax_id)=(12) is still referenced from table “saleitem”. QPSQL: Unable to create query

I have read the fine 3.2.2 xtpos manual cover to cover and there are no update instructions.

I am not reporting this as a bug as it may simply be procedural; ie, I wonder if I’m supposed to disable or remove xtpos from 3.2.2 before updating the core application. An excellent addition to the 3.3.0 documentation would be the upgrade procedure.

So what I need to know is, what are the basic steps I need to follow to upgrade with an xtpos in place. If the above result is a bug I will be happy to report it, but I suspect that it is not.

Arthur Knight Hammer