xTuple.com xTupleU Blog & News Customer Support

Menus On New User

I got the PostBooks demo setup in order to show our Accounting department and see if they are interested. I’m now trying to setup an appropriate user for them. I have the role setup and the user under that role. Functionally, they have access to everything specified. However, no items seem to be showing up under “Main Menu”. I know they can get to the functionality in other ways but, I want everything to be setup as complete as possible.

I’ve compared the settings to the preset admin account and don’t see anything different. As you can see in the screenshot below, she is set to “Show Accounting Menu”. However, (next screenshot) it is not there when she logs in.

Also, I used the search and found some references to defining modules in System → Preferences but that is identicasl to the Menus screen above so I assume it is from an older version. Feel free to correct me if I’m wrong.

The three areas that need to be set up are:

  1. User Account Menus (which you have shown)
  2. User Preferences (under System for Windows/Linux, under xTuple on Mac)
  3. Privileges, specifically, the user HAS to have Desktop privileges to see anything.

For #3, you want to scroll though the different privileges available, starting with accounting, but look through them all, and make sure that they have the access to the Desktop.

The Menus setup in the User Account screen and User Preference are the same and should work the same in either of the screens. I think the problem is what Wally described: make sure they have the Desktop privileges.

Thank you for the phone call, Wally. That got me where I needed to be.

Hi. I am having the same issue in 4.11.3, but it works fine in 4.10.1
i gave all the privileges I could find to the new user, the two instances look identical when I compare the xtdesktop line by line but it works in one not the other.

Kurt,

  • System > Maintain User Accounts
  • double-click on the user
  • Privileges tab
  • select Desktop from the combo box (dropdown list)
  • click ADD ALL ->>
  • click SAVE
  • tell the user to log out of the application and log back in

If you’ve done all of these things and the user still has an empty list under MAIN MENU on the main application window, let us know. If you can’t follow all of these steps exactly, also let us know.

One more thing: What version of xtdesktop are you using? System > Design > Packages and look for xtdesktop. The version number should be on the same line, probably in the 3rd column.

Gil

Says desktop is 4.0.11. I had already tried the steps you suggested and I was able to complete them but still no change.

Kurt,

If you’ve set the user’s menu-visibility preferences and given him/her the right permissions as Wally suggested, the menu in the main application window should just work. I spent some time this morning trying to get it to fail and couldn’t. I’m not even sure what questions to ask at this point to find the problem.

Gil

I have tried 4.11.3 in Ubuntu 18.04 VirtualBox and in 18.10. I added back ports to Debian 9 on a bare metal but all instances have that blank space. It seems a small thing but those welcome screens actually Make the system seem much more user friendly. I’ll revert to 4.10.0 that’s in the repositories.