xTuple.com xTupleU Blog & News Customer Support

Install Postbooks on Ubuntu 13.10 on a USB stick

I've just installed Ubuntu 13.10 to test on a USB stick, and Ubuntu is working great. Can I download Postbooks and run it on the USB drive? If possible, what is best practice in such a set-up?

I don't intend this to be a permanent situation. Just exploring options at the moment.

I got a good tip on another topic in this forum <http://www.xtuple.org/forums/technology/linux/feedback-about-official-packages-debian-and-ubuntu#comment-14677>. 

So far  I have done the following.

sudo -i

apt-get install g++-multilib    (I ended up having to remove this package and performing another apt-get update and re-installing the ia32-libs)

cd /etc/apt/sources.list.d

echo "deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list

apt-get update

apt-get install ia32-libs

Then I downloaded xTuple-4.2.0-linux-installer.run

chmod +x xTuple-4.2.0-linux-installer.run


The install proceeds and the files are created in /opt like I would expect, but for some reason I am unable to launch xTuple.  If I manually call /opt/xTuple-4.2.0/xTupleERP/xtuple , I get the following response:

error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

Any ideas?


Apparently I messed up somewhere along the way, but xTuple is working great on Trusty Tahr so far.  I removed the g++-multilib library, performed apt-get update, and reinstalled ia32-libs.  She is working like a charm.  No more Virtualbox xTuple for me!

Sweet, thanks. I am running 64bit system. Grabbed xTuple-4.2.1-linux-installer.run, changed its permissions to executible- and then nothing happened when I tried to run Postbooks. Are the libraries you mentioned this:


You need to install the ia32-libs to allow 32bit application support on your 64bit system.  Without those libraries you will not get the application to run.

Certainly can, our application is what is called a "portable" app -- you can extract it from the archive and run it in place. 

You'd want to download the GUI Client package, from here: http://sourceforge.net/projects/postbooks/files/02%20PostBooks-GUIclient-only/ extract the contents where you want and then run PostBooks from there. Please note that I am describing the client side only, assuming the PostgreSQL database is on another computer. You can run PostgreSQL on that laptop too but its a little bit more permanent of an installation. 

Ubuntu 13.10 removed the "ia32-libs" package that xTuple uses to run in 32bit mode on a 64bit laptop. You will need to install the proper Qt compatibility libs to support 32bit if youre running the 64bit Ubuntu.  

Attempting to install ia32-libs, but receive an error from the Ubuntu Software Center saying that:

Dependency is not satisfiable: ia23-libs-multiarch

"This is a transitional package depending on ia32-libs-multiarch, an i386-only metapackage that depends on all of the libraries that were previously included in this package."

I am getting the impression that If I can run Postbooks on the USB stick once, all the dependencies involved may not persist after a system shutdown.

I kept running into this multiarch support dependency issue.


In home/ubuntu/Downloads

mkdir xTuple

downloaded xTuple-4.2.1-linux-installer.run to Downloads folder

mv to xTuple folder


performed commands:

sudo dpkg –add-architecture i386

sudo apt-get update


then make it executible & execute

chmod +x xTuple-4.2.1-linux-installer.run

./ xTuple-4.2.1-linux-installer.run

***Nothing happens***


So trying to install **ia32-libs**:

sudo apt-get install ia32-libs


Package ia32-libs is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However the following packages replace it:

lib32z1 lib32ncurses5 lib32bz2-1.0


E: Package 'ia32-libs' has no installation candidate


I poked around a bit more, and have had some success.


So instead I tried this:

sudo apt-get install lib32z1


then made .run file executible again:

chmod +x xTuple-4.2.1-linux-installer.run

and executed with:



and this was the result:


Welcome to the xTuple ERP 4.2.1 Setup Wizard.


This wizard will walk you through the installation of xTuple Desktop Client and

optional components.


I've followed all the prompts trough the wizard, opted to include both the client and updater, and received an installation successful




0% ______________ 50% ______________ 100%




Thank you for installing xTuple ERP 4.2.1.


But the contents of home/ubuntu/xTuple is still only xTuple-4.2.1-linux-installer.run

when I attempt to execute with:


I am taken back to the installer wizard. So how do I run the client?


I should point out that I have a working Postbooks on Ubuntu 12.04, and so did not choose to start a free trial.

For documentation's sake I did successfully install the postbooks client on a pen drive. Did not know when creating the bootable pen drive that I needed to make it writable, as per an option when setting the pen drive up. In fact, when re-creating the pen drive I made it 32 bit LTS, and the xTuple install when as expected. 

Now off to put Postgresql-9.1 on the pen drive too. 

David, as you say, ubuntu no longer supports ia32-libs. I just want to install the latest xtuple client on Ubuntu 13.10. Do I have to go thru all of these steps now?


I tried installing the packages that were supposed to replace ia32-libs, but that didn't work for me. It seems to be really complicated now to run the client on recent versions of Ubuntu/Linux. 


Here is the solution that ended up working for me:

Install Synaptic from terminal window

sudo apt-get install synaptic

Launch synaptic and goto “settings > Repositories”

click “other software > add”

insert this line in the box

deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse

click ok and close synaptic

in terminal

sudo apt-get update

in terminal

sudo apt-get install ia32-libs


See my post in another area of the forums here regarding using Ubuntu 14.04LTS and multiarch packages.