xTuple.com xTupleU Blog & News Customer Support

4.11.3 Work Order Cluster Slow in the Cloud

I’m testing 4.11.3 in the cloud.
In 4.9.3, the work order cluster returns the work order 175156-1 but in 4.11.3, it is 175156-001.
It takes about 8-12 seconds when you key in a work order number for it to populate.
Is this a known issue.

Marsha,

The change in work order number format is a response to requests from customers. The 8-12 second time lag sounds like a performance bug that we haven’t heard before.

Gil

Gil, can you check and see if it is happening on your end?
We have over 117,000 work orders, 1300 of which are not closed.
Thanks

Marsha,

I created a database with 120,262 work orders:

masterref=# select count(*), wo_status from wo group by 2;
 count  | wo_status 
--------+-----------
    249 | C
 110012 | E
  10001 | O
(3 rows)

In the Explode Work Order window, there is a slight hesitation when keying a work order number, and none when tabbing out of the cluster. There’s 1-3 second lag when typing in the work order cluster on the Implode Work Order window, but then it’s looking at over 100,000 candidate records. This doesn’t seem unreasonable.

Gil

Can you check the performance of the print work order form screen.

The Print Work Order Form window includes the closed work orders so the cluster is going to be slow there. You could probably script turning off closed work orders, perhaps even adding a checkbox to control it. If you need help with that then contact us directly.

Gil